Elevated API Errors

Incident Report for TrackVia

Postmortem

Post-incident summary

What happened

After our scheduled release on April 27, a portion of customers encountered an unexpected authentication error page in two narrow scenarios on forms: saving a record that fell outside the current view's filter, and saving on a form that had been idle long enough for a background credential refresh to occur.

Customer impact

Affected users saw a full-page authentication error instead of the expected in-app message or a normal successful save. Refreshing the page allowed work to resume. No customer data was exposed, lost, or modified as a result of this issue.

Root cause

The application periodically refreshes the secure credentials used to authorize requests. A change in this release exposed a latent issue in which certain read requests on form pages continued to use a previously cached credential after it had been refreshed. When that older credential was no longer valid, the request was rejected and a full-page error was shown.

Resolution

We changed how authentication credentials are supplied to the affected read operations so that all requests use the current credential and automatically recover from a just-expired credential. The fix has been deployed and verified.

Preventive actions

  • Added automated regression coverage for the "record saved outside the active view filter" flow, including verification that the friendly in-app message — not a full-page error — is shown.
  • Added automated regression coverage to confirm that authentication errors from expired credentials are handled transparently without surfacing a full-page error.
  • Strengthened internal review practices for shared foundational components that flow into customer-facing releases.

We appreciate your patience. If you believe you experienced an impact that has not been resolved, please reach out to support@trackvia.com.

Posted May 13, 2026 - 16:25 MDT

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 18:05 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2026 - 17:55 MDT

Identified

On Monday, April 27 at approximately 2:00 PM MT, a scheduled deployment to the commercial environment resulted in an increase in HTTP 401 authentication errors when accessing application resources. Some users may have needed to refresh the application to continue working.

The issue has been identified, and a patch is scheduled for deployment to all affected accounts on Tuesday, April 28 to fully resolve the problem.
Posted Apr 27, 2026 - 19:35 MDT
This incident affected: Application Services (Commercial Cloud).