Commercial - Performance Degradation

Incident Report for TrackVia

Resolved

TrackVia commercial Cloud services were unavailable for from 1:30PM to 2:04PM MT on Sep 17, 2025.

[Resolved] This incident is now resolved. After a monitoring period we have observed no further degraded performance across TrackVia Commercial Cloud Services.

Problem: The problem was caused by excessive concurrent requests creating significant chained calculated field queries to occur across multiple databases resulting in both database and application server disruption.

Impact: Users interacting with TrackVia Commercial Cloud Services experienced slowness and inability to access the web application.

Causes: Excessive concurrent requests, leading to high memory usage and service errors.

Remediation: Targeted termination of high-memory processes were executed to free up contending resources. All instances were restarted, connections were restored, and culprit queries were isolated. We are collaborating with necessary parties to optimize the offending queries to prevent this in the future.
Posted Sep 17, 2025 - 13:30 MDT