Scheduled Maintenance - HIPAA Cloud
Scheduled for Jun 26, 09:00 - 13:00 MDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 09, 2021 - 11:01 MDT
Scheduled
System maintenance is scheduled for the HIPAA Cloud on June 26, 2021 from 9:00AM MT through 1:00 PM to perform database upgrades. TrackVia will be unavailable for minimum of 1 hour during this maintenance window.
Posted May 24, 2021 - 10:36 MDT
This scheduled maintenance affects: HIPAA Cloud.